Can't see comic images? Use a firewall? Tips here.

For requests for help from CG administrators, Wranglers, and experienced CG members. Please read the FAQ before posting. Also look at CG Wiki for tutorials and how-tos written by other CG webtoonists.

Can't see comic images? Use a firewall? Tips here.

Postby STrRedWolf on Sat Oct 01, 2005 10:07 pm

If you pull up a Comic Genesis site, and can't see any images or the webcomic itself, AND you run a privacy or security software firewall, this thread is for you. Comic artists/authors would need to post seperately incase they got their HTML wrong.

So what's causing the problem? Comic Genesis requires browsers to send the "Referral" header in each request for comics and images. This is checked to see if comics and images are being used on non-CG sites -- If they are, they automatically are denied.

However, some software companies like Symantec, Zone Alarm, and others think that the "Referral" header is unnessisary, and strip it out. This causes CG's servers to say "You're pulling directly. DENIED!" to any comic or image request.

Why does CG check that header? We check it so noone can rip our webcomics eazily. We save alot of bandwidth that way, and bandwidth costs money. If we didn't, artists here would have no CG to go to.

Is it CG's fault that Symantec et all doesn't play nice? No. It's purely on the software firewall's fault.

I have Norton Internet Security 2005 or 2004. How do I fix it?
  1. Open up Norton Internet Security, and select Privacy Control. It should have a "Configure" button. Hit it, and it'll pop up a new window.
  2. Hit "Advanced," then "add site." Type in "comicgenesis.com" and hit OK.
  3. Hit "comicgenesis.com" in that list, and in the "Global Settings" tab, uncheck "Use default settings" and check "Permit" on "Information about your browser" and "Information about visited sites".
  4. Hit "OK" and close everything up.

Note: You may have to add CG domains that do not have .comicgenesis.com (example: stalag99.net).

I haven't upgraded from Norton Personal Firewall 2003. How can I fix this problem?
Follow the same proceedure, but to get to the right screen, you need to open up Norton Personal Firewall, and in the Options Menu hit "Personal Firewall." Select the Web Content tab. Everything else is the same as the newer software.

I have an older version of Norton Personal Firewall. How about me?
You're similar. Follow the instructions for 2003, and you'll get a window with an "Advanced Options" button. Click on that, and you'll be able to add "comicgenesis.com". Then select "comicgenesis.com" from the list, check "Use these rules" and under "Referer" set it to "Permit." Hit OK out of everything and close it up.

I have Zone Alarm Pro. Am I screwed?
  1. Open Zone Alarm Pro and click on "Privacy" on the left side.
  2. Click on the "Custom" button in "Cookie Control."
  3. Select "Cookies" and uncheck "Remove Private Header Information."
  4. Hit "Apply", then "OK", and exit.

Hey! We have eTrust EZ Firewall! What about us?
I hope you visited a .comicgenesis.com site before you came here. EZ Firewall likes to record where you've been.
  1. Open EZ Firewall and click "Privacy" on the left side of the window. Select the "Site List" tab.
  2. Locate all .comicgenesis.com domains (and other CG-parked domains), and under Private Header right-click the "X". Select "Allow" for every one.
  3. Exit EZ Firewall.


I don't have any of those, but I do run a software firewall.
If you can punch a hole for us, let us know how!

I don't use any of those. I use Firefox instead! But I still have the same problems.
Try this: Open up "Options" in the Tools menu. On MacOS, it's "Preferences" in the Firefox Menu, and in Linux/Unix, it's "Preferences" in the "Edit" menu. Click "Web Features" and make sure "Load Images" is checked, but "for the origionating website only" is unchecked. You may want to hit "Exceptions" though, and make "comicgenesis.com" allowed to load images.

Do I really need a software firewall?
If you have a Cable/DSL router (aka a NAT/IP MASQ firewall) or a hardware firewall between you and your Cable/DSL modem (or your Net connecton in general), you can probably get away without one. Most hardware firewalls will block all incomming connections from the Internet at large unless you tell them to forward them to you. Nice level of control, eh? For added security, use Firefox for your web browsing instead of IE -- it generally has less holes and isn't integrated into Windows like IE is (a good visual is that IE and Windows are together in bed -- and they're not using protection). Bugs in Firefox are fixed faster, plus you can search the bug list as well as track them yourself.
User avatar
STrRedWolf
Confuzzled CG Admin
Confuzzled CG Admin
 
Posts: 2570
Joined: Fri Jan 01, 1999 4:00 pm
Location: undef;

 

Return to Help Center



Who is online

Users browsing this forum: No registered users and 0 guests